var add = (a, b) => a + b;
I think that this is a step in the wrong direction.
Angus Croll writes something that I strongly agree with:
I can't shake a nagging feeling that this proposal (in its current form) is flawed to the extent that it might actually make new developers more confused than they already were.
I also think that the
=> syntax is confusing. These functions can't be constructors, nor can they have names, nor can they touch the
arguments variable, and the context is different. So...people will think of them as mini-functions. If it were purely a syntactic shorthand, fine. But these differences will confuse people, I guarantee it.
I will probably not be using the